Too Many "Goods" Problem…

This topic contains 6 replies, has 2 voices, and was last updated by Anindo Anindo 2 months, 1 week ago.

  • Author
    Posts
  • #59986
    pmark23
    pmark23
    Participant

    Most of our shipments are giving this error:

    Canada Post Create Shipment Error:Error Code: 7041 Error Msg: There can only be 8 lines of goods for a shipment using the small packet service. Please reduce the number of goods or change the service.

    When the plugin is filling in the customs part of the form, it’s not filling in the form properly.

    If someone buys 10 Grapple Grommets, the plugin fills in the customs area as:

    1 Grapple Grommet
    1 Grapple Grommet
    1 Grapple Grommet
    1 Grapple Grommet
    1 Grapple Grommet
    1 Grapple Grommet
    1 Grapple Grommet
    1 Grapple Grommet
    1 Grapple Grommet
    1 Grapple Grommet

    Instead it should look like this:

    10 Grapple Grommet

  • #60060
    Anindo
    Anindo
    Keymaster

    Hi Mark,

    It appears that you are sending 10 packages with Small Packet service which is causing the problem.
    This service permits 8 packages only.

    Can you please check the box that you are using to pack the goods? If you want to have 2 or items packed inside one box, then kindly define a custom box of appropriate dimensions. Here is a video for your reference :

  • #79608
    pmark23
    pmark23
    Participant

    No, that’s not the problem.

    The problem is that identical items are sent to Canada Post as individual items rather than multiples of the same item.

    I can manually create the label no problems (even as a Small Packet), but the plugin is sending the items to the Canada Post server as individual items rather than X number of the same item.

    It doesn’t matter if the Small Packet service is used or not — all Canada Post shipments have this problem.

    We paid for this plugin once, and once this problem is fixed I’ll continue paying for it. This is a big issue for us.

  • #79627
    Anindo
    Anindo
    Keymaster

    HI,

    That is happening because of the Parcel Packing option in plugin settings page.

    If the option has ‘Pack into boxes with weights and dimensions’, then the make sure that the box is defined with dimensions that can accommodate the products.
    If the option is ‘Pack items individually’, then that means each item will go individually.

    Kindly make sure of these points and your problem will be resolved.

  • #79731
    pmark23
    pmark23
    Participant

    No, that’s not it.

    The error is:

    Canada Post Create Shipment Error:Error Code: 7041 Error Msg: There can only be 8 lines of goods for a shipment using the small packet service. Please reduce the number of goods or change the service.

    The items I’m shipping are miniscule and dozens of them would fit in our smallest package. That has nothing to do with Parcel Packaging and everything to do with how multiple identical items are sent to Canada Post by the plugin.

    Do you see where the error message states “There can only be 8 lines of goods for a shipment using the small packet service.”? That is the problem.

    If someone buys 10 Grapple Grommets, the plugin currently fills in the Customs area as:

    1 Grapple Grommet
    1 Grapple Grommet
    1 Grapple Grommet
    1 Grapple Grommet
    1 Grapple Grommet
    1 Grapple Grommet
    1 Grapple Grommet
    1 Grapple Grommet
    1 Grapple Grommet
    1 Grapple Grommet

    Instead it should look like this:

    10 Grapple Grommet

    And then there would be room for 7 more items in the package. There’s even a box in this part of the label for the number of items.

    The label is made manually on the Canada Post site like this with no problems.

    The Canada Post plugin needs to send the items as “6x ITEM A”, “3x ITEM B” (two goods total) rather than “ITEM A”, “ITEM A”, “ITEM A”, “ITEM A”, “ITEM A”, “ITEM A”, “ITEM B”, “ITEM B”, “ITEM B” (still two goods total, but listed as if there’s 9 goods.) I don’t know how it’s formatted exactly but I think you should get the point.

  • #79732
    pmark23
    pmark23
    Participant

    I was trouble-shooting another issue with the plugin (one of the products had zero weight) and captured the XML being sent to Canada Post. Here’s the relevant snippet:

    <item>
    	<customs-number-of-units>1</customs-number-of-units>
    	<customs-description>Tile Power Strip</customs-description>
    	<unit-weight>.1</unit-weight>
    	<customs-value-per-unit>2</customs-value-per-unit>
    </item>
    <item>
    	<customs-number-of-units>1</customs-number-of-units>
    	<customs-description>Tile Power Strip</customs-description>
    	<unit-weight>.1</unit-weight>
    	<customs-value-per-unit>2</customs-value-per-unit>
    </item>

    Here the customer bought two “Tile Power Strip” items, and they’re listed twice with the <customs-number-of-units> listed as “1” for each unit.

    Instead there should only be one <item> listed and <customs-number-of-units> should be “2”, like this:

    <item>
    	<customs-number-of-units>2</customs-number-of-units>
    	<customs-description>Tile Power Strip</customs-description>
    	<unit-weight>.1</unit-weight>
    	<strong><customs-value-per-unit>2</customs-value-per-unit></strong>
    </item>
  • #79748
    Anindo
    Anindo
    Keymaster

    Hi,

    Would it be possible for you to share the complete request and response to our support so that we can check and fix this?

    We will definitely check and correct it.

You must be logged in to reply to this topic.