Can’t load other addresses or payment methods, orange circle spinning…

XAdapter Forums Amazon Payments Gateway for WooCommerce Can’t load other addresses or payment methods, orange circle spinning…

This topic contains 3 replies, has 2 voices, and was last updated by Anindo Anindo 1 month, 3 weeks ago.

  • Author
    Posts
  • #54160
    Doug
    Doug
    Participant

    I have the plugin installed and it will allow a customer to checkout, however, it will not allow you to select other addresses or payment methods from your Amazon account. I can see payment method 1 of 2, but the arrows don’t change to the second. Same on addresses. You can see an orange circle turning behind those fields, but it never loads any more info. Please advise.

    Wheel Adapters, Spacers, and Hub Centric Rings

  • #54548
    Doug
    Doug
    Participant

    We are still having the same issue even after Xadatper closed our support ticket and said it was corrected. We paid $59 for support to get this issue resolved over a week ago. We plan get our money back through your 30-day money back guarentee.

  • #54586
    Anindo
    Anindo
    Keymaster

    Hi Doug,

    We sincerely apologise for the miscommunication. There was a slight confusion from our team due to which the ticket was accidentally marked as solved.

    We will surely correct this problem in a few hours from now!
    If we are not able to do this, we will refund your money. No worries on that.

    Our team will get back to you in a few hours.

  • #54588
    Anindo
    Anindo
    Keymaster

    Hi Doug,

    On analysing this, we found that the amazon widget’s javascript was blocked by the browser. The reason is – It is not a valid javascript return.

    To solve this,
    you need to login to your Amazon seller account. There, below the web settings, you need to add the javascript origin as well as return URL.
    Origin URL – Your website URL (For ex – http://www.example.com)
    Return URL – Checkout URL (For ex – http://www.example.com/checkout)

    You can refer the screenshot here – https://ibb.co/hQ1dYw

    Once you make these changes, the problem will be resolved. Please let us know if you have any query on this.

You must be logged in to reply to this topic.