Cannot generate tracking number/label

XAdapter Forums UPS Shipping Plugin with Print Label for WooCommerce Cannot generate tracking number/label

Tagged: 

This topic contains 2 replies, has 2 voices, and was last updated by Alex Alex 1 year, 4 months ago.

  • Author
    Posts
  • #74685
    Alex
    Alex
    Participant

    Hi,

    Our plugin has been working fine for almost a year, but now we’re suddenly unable to generate shipping labels. In debug mode, this is the error that we’re given (I altered some of the personal data pertaining to our access number, password, and user id for privacy reasons).

    <?xml version=”1.0″ encoding=”UTF-8″ ?><AccessRequest xml:lang=”en-US”><AccessLicenseNumber>PRIVATE</AccessLicenseNumber><UserId>PRIVATE</UserId><Password>PRIVATE</Password></AccessRequest><?xml version=”1.0″ ?><ShipmentAcceptRequest><Request><TransactionReference><CustomerContext>4095</CustomerContext><XpciVersion>1.0001</XpciVersion></TransactionReference><RequestAction>ShipAccept</RequestAction></Request><ShipmentDigest></ShipmentDigest></ShipmentAcceptRequest>

    SHIPMENT ACCEPT RESPONSE:
    <HTML><HEAD>
    <TITLE>Access Denied</TITLE>
    </HEAD><BODY>
    <H1>Access Denied</H1>

    You don’t have permission to access “http://www.ups.com/ups.app/xml/ShipAccept” on this server.<P>
    Reference #18.894eaad1.1529389307.59410a23
    </BODY>
    </HTML>

    Do you have any idea what’s going on? Any help would be great.

  • #74698
    Anindo
    Anindo
    Keymaster

    Hi Alex,

    UPS has changed it’s URLs for querying the API.
    Can you please approach our support team here?

    They will be providing you a fix for it.

  • #74713
    Alex
    Alex
    Participant

    Great! I’ll do that right away.

You must be logged in to reply to this topic.